I came across a segment of Java code like this during a code review:
String str = "" + 10;
Sometimes I really don’t know what’s in people head. Isn’t it a lot more simpler/clearer/better/faster to do it as:
String str = "10";
If it is up to me, we should banish people writing code like this to write single line of code again.